Roll-out of new EUMETCast Client Software (Tellicast), EKU hardware and drivers

New EUMETCast packages are available on FTP and will also be distributed on EUMETCast.

Thursday, 21 February 2019

These are:

Tellicast client software 2.14.5:
32bit installer version for 32/64 bit Windows OSes
Native 32bit and 64bit Linux versions, in RPM, DEB and TGZ packages

EKU driver software SAC (Safenet Authentication Client) 9.0, for Windows and Linux, 32bit and 64bit systems

New EKU hardware is available for new installations and to replace broken EKUs:
eToken PRO Java 72K, blue (delivered from February 2019)
Safenet eToken 5110, black (planned in future)

The new packages are available on our FTP server:
ftp://ftp.eumetsat.int/pub/OPS/out/user/EUMETCast_Support/EUMETCast_Licence_cd/
ftp://ftp.eumetsat.int/pub/OPS/out/user/EUMETCast_Support/tellicast-client-pre-release/

They will also be distributed on EUMETCast from 22 February 2019, twice a day at 08:50 and 16:50 UTC, on 'Info-Channel-1'.

Is this upgrade mandatory?

EUMETCast client

The EUMETCast client version 2.14.5 is compatible with current and older EKU drivers. Therefore, it is recommended for users to upgrade to the latest EUMETCast client version.

Users can decide to keep the existing version running, in order to avoid any interruption. However, EUMETSAT will only provide support for the latest client version. If problems are reported, in the first instance EUMETSAT will ask users to upgrade to the latest client version.

EKU drivers

The new drivers are compatible with all types of EKUs. If users decide to stay with the old drivers, the upgrade must be applied, at the latest, when replacing the EKU with a new type.

DVDs with the new packages are under preparation for new users.

For more information, contact our User Service Helpdesk.

 
By continuing to use this website, you are giving consent for EUMETSAT to store certain information about you. To learn more about what information EUMETSAT collects and how it is used, please view our Terms of Use page.