Tutorial on EUMETView Web Map Service Access Through QGIS
This page intentionally left blank
Document Change Record

<table>
<thead>
<tr>
<th>Issue / Revision</th>
<th>Date</th>
<th>DCN. No</th>
<th>Changed Pages / Paragraphs</th>
</tr>
</thead>
<tbody>
<tr>
<td>V1</td>
<td>03/08/2016</td>
<td></td>
<td>First release.</td>
</tr>
</tbody>
</table>
Table of Contents

1 INTRODUCTION..................................................................................................................................................5

2 HOW TO USE THE EUMETSAT WMS SERVICE ON QGIS ............................................................................6
  2.1 What is QGIS ..................................................................................................................................................6
  2.1.1 How to install QGIS .............................................................................................................................6
  2.1.2 How to start with QGIS .........................................................................................................................7
  2.2 How to load EUMETView WMS service on QGIS ........................................................................................7
  2.3 How to overlay maps from EUMETView WMS Service with other EUMETSAT data or data from other sources .........................................................................................................................13
  2.4 How to display a basemap under EUMETView WMS Service data ................................................................16
  2.5 Save a georeferenced image from the map ................................................................................................17
  2.6 Time animation of EUMETSAT images .....................................................................................................17

Table of Figures

Figure 1: QGIS website ..........................................................................................................................................6
Figure 2: QGIS Graphical User Interface ...............................................................................................................7
Figure 3: Add a WMS layer in QGIS .......................................................................................................................8
Figure 4: Add WMS window .....................................................................................................................................8
Figure 5: Create a connection ...............................................................................................................................9
Figure 6: List of available layers in EUMETView WMS Service ..........................................................................10
Figure 7: Add WMS window (parameters to choose) ..........................................................................................11
Figure 8: EUMETSAT Airmass layer displayed on QGIS map canvas .............................................................12
Figure 9: EUMETSAT Airmass layer properties ..................................................................................................13
Figure 10: Display layers from different sources ................................................................................................14
Figure 11: Enable on-the-fly transformation .......................................................................................................15
Figure 12: Enable on-the-fly transformation .......................................................................................................15
Figure 13: Install OpenLayers Plugin ..................................................................................................................16
Figure 14: OpenLayers Plugin as a base map .......................................................................................................16
Figure 15: OpenLayers Plugin as a base map .......................................................................................................17
Figure 16: TimeManager Plugin tool ....................................................................................................................18
Figure 16: GetCapabilities response xml document ..........................................................................................19
Figure 18: How to complete the required fields in TimeManager (layer name, start date/time, end date/time) ...........................................................................................................................................19
Figure 19: Settings for EUMETSAT WMS Service layer .....................................................................................20
Figure 20: Animation of EUMETSAT WMS Service layer (Play, time frame size, export video) ......................20
1 INTRODUCTION

This guide describes how users can access data via the EUMETSAT EUMETView WMS Service on their local machine. It explains the required steps to configure a connection from QGIS to the EUMETView WMS service server (published at the URL http://eumetview.eumetsat.int/geoserver/wms?service=wms&version=1.3.0&request=GetCapabilities) in order to display EUMETSAT data on QGIS.

The benefit of accessing the EUMETView WMS server through a GIS Desktop application is that this allows the user to exploit the service on its local machine, therefore giving the advantage to load EUMETSAT data directly on user’s own maps, and to overlay user’s own geodata directly on EUMETSAT data, this leading to an enhancement of user’s data analysis capability.

If you need an explanation of what is EUMETView WMS Service is, which are the available layers, and a detailed description of WMS Service characteristics and usages, please refer to the guide “Tutorial on EUMETView Service – Introduction” in the same web page of this guide.
2 HOW TO USE THE EUMETSAT WMS SERVICE ON QGIS

2.1 What is QGIS

QGIS is A Free and Open Source Geographic Information System (license GNU GPL). It allows visualization, management, editing, and data analysis, and also printable maps composition. It can provide the users extensive analytical functionalities through integration with other open source applications (GRASS GIS, PostGIS, R, Saga GIS and others) for geodata analysis and it has many plugins to extend its capabilities.

It can be run on different operating systems, including Linux, Unix, Mac OSX, and Windows, plus a mobile version for Android which is under development.

It can support a large number of data formats (vector, raster, geodatabases, Drawing Exchange Format etc). Besides, it can act as a client for most of OGC specifications (WMS, WCS, WFS, etc) to allow the retrieval of data from external online sources. In particular, QGIS understands WMS 1.1, 1.1.1 and 1.3 server versions.

2.1.1 How to install QGIS

You can download QGIS installers for the different operating systems at https://www.qgis.org/en/site/forusers/download.html.

![Image of QGIS website](https://www.qgis.org/en/site/forusers/documentation.png)

*Figure 1: QGIS website*

2.1.2 How to start with QGIS

This is how QGIS GUI appears:

1. Table of contents (Layers Panel)
2. Map Area (Map Canvas)
3. Toolbar
4. Standard Menu Bar
5. Status Bar (Coordinates, Scale, CRS)

Figure 2: QGIS Graphical User Interface

2.2 How to load EUMETView WMS service on QGIS

As previously explained, a WMS is a service hosted on a remote server, and, like a normal website, can be accessed if you have the address to connect to the server.

The URL to the WMS Service is: http://eumetview.eumetsat.int/geoserver/wms.

The GetCapabilities operation of the EUMETView WMS Service can be found at the URL: http://eumetview.eumetsat.int/geoserver/wms?service=wms&version=1.3.0&request=GetCapabilities.

In order to add EUMETSAT data from the WMS Service, follow the next steps:

- Open QGIS Desktop (click on QGIS icon )
- Go to Layer ▶ Add Layer ▶ Add WMS/WMST Layer:
Figure 3: Add a WMS layer in QGIS

This will open the dialog window “Add Layer(s) from a WM(T)S Server”. If EUMETView Service is not yet in the list of available connections:

- Click on “New”:

Figure 4: Add WMS window

This will open the “Create new WMS connection” window.

- In “URL” paste the link to the EUMETView WMS Service.
• In “Name” choose a name for the connection, for example “EUMETView Service” (please, note that this name will be not the name of the displayed layer(s) but the name to identify the WMS service you are accessing, and it will be used in the Server Connection drop-down list). Since data are free available, there is no need to insert Username and Password.

• After you clicked on OK, the service will become available in the list of Server Connections.

![Create a new WMS connection](image)

**Figure 5: Create a connection**

• Click on “Connect” button to fetch the list of available layers. Once the connection is active, you can see the list of the available WMS layers in the list of layers. Every layer has an ID, a Name, a Title and an Abstract.

• The list of layers has a tree structure: the ID number 0 (first line) includes all the layers of the service. You can expand the list by clicking on the “+” sign to the left of the 0.
Now you can choose the layers you need to plot:
1. click on the layer of interest (for example, the layer named “msg:airmass”),
2. once you clicked on the layer, you can choose the image encoding (PNG, PNG8, JPEG, GIF or TIFF). See next table for a short description of different data formats. If your need WMS data to display or print a map, the PNG format is recommended,
3. choose the Coordinate Reference Systems between the ones available (the airmass layer’s default CRS is WGS84, EPSG: 4326),
4. choose the layer name that will be displayed in the QGIS Layers Panel.
5. click on “Add” button, then on “Close” button to close the connection window.
Figure 7: Add WMS window (parameters to choose)

Something about available image formats:

<table>
<thead>
<tr>
<th>IMAGE ENCODING</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>PNG/PNG8</td>
<td>It is a lossless compressed image format. PNG quality is better that other lossy formats such as JPEG. Use it if you want precise representations of the original data and transparency support.</td>
</tr>
<tr>
<td>JPEG</td>
<td>It is a quite common used format for lossy compression of digital images.</td>
</tr>
<tr>
<td>GIF</td>
<td>Graphics Interchange Format. It is a lossy format. It supports up to 8 bits per pixel for each image, allowing a single image to reference its own palette of up to 256 different colours chosen from the 24-bit RGB colour space.</td>
</tr>
<tr>
<td>TIF</td>
<td>Tagged Image File Format. It is a lossless format. TIFFs are uncompressed images, which contain many details and are very flexible in terms of colours. It is very flexible because a TIFF image can contain images and data within a single file by including the header tag.</td>
</tr>
</tbody>
</table>
• Now the chosen layer is added to QGIS and it is visible in the Map Area.

![Layers Panel](image)

*Figure 8: EUMETSAT Airmass layer displayed on WGIS map canvas*

• When the layer is displayed on the map, it is possible to use the typical GIS Desktop functions such as panning, zooming, scaling, adding and switching visible layers, change their opacity, switch CRS etc. Please, remember that the image you loaded on QGIS it is just an image. Is not a queryable image, so if you click on a pixel in the image you will not retrieve the value on that pixel of the geophysical parameter that the layer represents.

• If you want to view image properties, right-click on the layer and select “Properties”. This will display information (collected from the capabilities statements returned by the server) about the WMS server from the Metadata Tab. In the metadata section, you can find information either about Server Properties or about Layer Properties.
2.3 How to overlay maps from EUMETView WMS Service with other EUMETSAT data or data from other sources

If you want to add maps from another WMS Service, follow the steps described in the previous chapter (just change the URL to the WMS Service you want to use).

For example, if you want to compare EUMETSAT Dust product to Cloud Optical Thickness data (implemented by the Royal Netherlands Meteorological Institute (Koninklijk Nederlands Meteorologisch Instituut or KNMI):

- add Dust product from the EUMETSAT WMS Service,
- connect QGIS to the KNMI WMS Service (add the following URL http://msgcpp-ogc-realtime.knmi.nl/msgrt.cgi),
- choose the Cloud Optical Thickness layer (note that when add a new WMS layer on a map, it is recommended to chose PGN as format image, for a better transparency support).
If you want to overlay some EUMETView data layer on a layer with a different Coordinate Reference System from the allowed ones, you have to check that the QGIS option “Enable ‘on-the-fly’ CRS transformation” is selected. To select this option go to the Status Bar, on the bottom of the GUI and click on the button with the symbol of the world.

Figure 10: display layers from different sources
This will open the Project Properties window. Click on CRS label and then check the “Enable ‘on the fly’ CRS transformation”. This will allow the data to be re-projected in the required CRS.
2.4 How to display a basemap under EUMETView WMS Service data

You can also add a useful basemap to EUMETSAT data, for example, by using QGIS Plugin OpenLayers. To download OpenLayers Plugin, go to “Plugins” ▶ “Manage and install Plugins”. Use “OpenLayers” as search key, then click on the OpenLayers Plugin and click on “Install Plugin”.

![Figure 13: install OpenLayers Plugin](image)

In order to load OpenLayers maps on QGIS, go to “Web” ▶ “OpenLayers Plugin” and choose the type of map you want to load. Please, note that OpenLayers maps has a particular Coordinate Reference System (EPSG:3857), so we recommend to re-project your maps in this CRS.

![Figure 14: OpenLayers Plugin as a base map](image)
2.5  **Save a georeferenced image from the map**

You can save the map of the visible extent from QGIS as a georeferenced image, which can be used later and overlaid on other offline maps or geodata.

Go to “Project” ► “Save as Image” and choose the image format, the name and the folder in which you want to save the file.

![Image of QGIS interface with a georeferenced image]

**Figure 15: OpenLayers Plugin as a base map**

QGIS will save the image as the chosen extension and it will also create a world file with the CRS information (for example, if you save the file as a TIFF, you will have in the folder the .TIFF file and the .TIFFW one).

2.6  **Time animation of EUMETSAT images**

If you want to perform animation in a range of time on EUMETSAT WMS Service images, you need to download the TimeManager QGIS Plugin (to download and install it, please, refer to the instructions in the 4.4 paragraph).

Once you’ve installed the plugin, go to Plugins ► TimeManager ► Toggle Visibility. This will show the TimeManager tool on the base of the map canvas.
Add to QGIS map canvas the layer you want to animate.
- From the TimeManager Plugin tool, go to Settings ► Add Raster.
- Select the layer you want from the drop-down list (the list is fetched from the layers actually loaded on QGIS map canvas).
- Choose the start and end date and time for your animation. In order to be sure to choose available date and time, refer to the GetCapabilities xml document (link: http://eumetview.eumetsat.int/geoserver/wms?service=wms&version=1.3.0&request=GetCapabilities)
For example, if you want to animate Meteosat airmass layer, from July 10th at 00:00 to July 11th at 00:00, you will fill in the required fields in this way, then click OK.

After clicking on OK, adjust the last settings: in Time Format use the format 
%Y-%m-%dT%H:%M:%S.%fZ
Check also “Ignore for detect empty”. Then click on OK.
Figure 19: Settings for EUMETSAT WMS Service layer

- Once you click on OK you will return on QGIS map canvas. Choose the time frame size (in this case 15 minutes or more, since Meteosat Airmass time resolution is 15 minutes), then click on the PLAY button (►). You can save the video as a series of images or a video file.

Figure 20: Animation of EUMETSAT WMS Service layer (Play, time frame size, export video)